路由器单臂路由实验

一、实验目的

  1. 进一步理解路由器配置的基本原理
  2. 掌握VLAN间路由单臂路由的配置
  3. 掌握路由器子接口的基本命令配置

二、应用环境

单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。

三、实验拓扑

实验拓扑如下,实验设备:2811路由器一台、二层交换机一台、PC机两台、直通线三根。

四、实验要求

设备 接口 IP
路由器A F0/0.1 192.168.1.254/24
路由器A F0/0.2 192.168.2.254/24
PC1 FastEthernet0 192.168.1.1/24
PC2 FastEthernet0 192.168.2.1/24

五、实验步骤

第一步:给PC设置IP地址(略)

第二步:给交换机A创建vlan

Switch(config)#
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#

第三步:给交换机设置链路类型并添加端口

Switch(config)#
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#no shutdown
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan all
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#no shutdown
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/3
Switch(config-if)#no shutdown
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit 
Switch(config)#

第四步:给路由器A创建子接口

Router(config)#
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/0.1
Router(config-subif)#no shutdown
Router(config-subif)#ip address 192.168.1.254 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastEthernet 0/0.2
Router(config-subif)#no shutdown
Router(config-subif)#exit
Router(config)#

第五步:给路由器A子接口配置VLAN号、封装格式和IP地址

Router(config)#
Router(config)#interface fastEthernet 0/0.1
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.1.254 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastEthernet 0/0.2
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.2.254 255.255.255.0
Router(config-subif)#exit 
Router(config)#

第六步:测试

若实验成功,PC0可以PingPC1,如Ping结果不通,表明实验配置错误,应检查IP地址或线缆是否配置正确,封装格式是否配置。

六、相关配置命令详解

1、encapsulation dot1Q
命令:encapsulation dot1Q
功能:配置以太网子接口VLAN号,封装格式为802.1Q。
命令模式:其他配置模式
使用指南:实现VLAN封装格式遵循IEEE制定的802.1Q标准,只能与同时遵循802.1Q标准的交换机或其它有VLAN功能的设备兼容。