链路聚合

链路聚合是指将交换机上的多个端口分别连接,聚合成一个逻辑端口,以增加交换机之间的连接带宽,同时提供冗余链路的网络方式。
链路聚合一般用来连接一个或多个带宽需求大的设备,例如连接骨干网络的服务器或服务器群。

链路聚合的优点


1、增加网络带宽
链路聚合可以将多个链路捆绑成为一个逻辑链路,捆绑后的链路带宽是每个独立链路的带宽总和。

2、提高网络连接的可靠性
链路聚合中的多个链路互为备份,当有一条链路断开,流量会自动在剩下链路间重新分配。

3、负载均衡
通过内部控制,可以合理地将数据分配在被聚合的各条链路上,实现负载分担。

链路聚合时需坚持一下原则

  1. 通道中的端口配置在同一Vlan中(access端口),或全部设置为trunk链路。
  2. 将通道中的所有端口配置在相同速率、工作模式和数据封装类型。
  3. 将通道中所有端口的安全功能关闭(默认都是关闭的)。
  4. 一般链路聚合最大组数为6,组内端口数量最多为8。

交换机汇聚链路配置:

sw1(config)#interface range f0/1-3

sw1(config-if-range)#duplex full 

sw1(config-if-range)#speed 100

sw1(config-if-range)#switchport mode trunk 

sw1(config-if-range)#switchport trunk allowed vlan all

sw1(config-if-range)#channel-group 1 mode on

交换机端口安全

交换机端口安全机制是工作在交换机二层端口上的一个安全特性,它的功能是:

根据MAC地址来做对网络流量的控制和管理。

比如MAC地址与具体的端口绑定,限制具体端口通过的MAC地址的数量;或者在具体的端口不允许某些MAC地址的帧流量通过。

原理:
当一个端口开启了端口安全特性以后,交换机将检查从此端口接收到的帧的源MAC地址,并检查在此端口上配置的最大安全地址数。若此帧的源MAC地址存在于安全地址表中,则直接将直接转发帧;若安全地址数没有超过最大安全地址数量,并且此帧的源MAC地址不在安全地址表中,则交换机学习此MAC地址,将其添加到安全地址表中,进行后续转发。

安全违例处理模式

Protect(保护模式):当安全地址数目超过最大数目后,安全端口会丢弃来自非安全地址的数据帧。

Restrict(限制模式):当违例发生时,安全端口会丢弃来自非安全地址的数据帧,并发送一个trap通知。

Shutdown:违例发生时,安全端口会丢弃来自非安全地址的数据帧,关闭端口并发送一个trap通知。

Sw1(config)#interface  f0/1

Sw1(config-if)#switchport mode access

Sw1(config-if)#switchport  port-security

Sw1(config-if)#switchport  port-security  maximum  2 //设置接口上安全地址的最大数是2,默认值是128

Sw1(config-if)#switchport  port-security  violation  shutdown //设置处理违例的方式为shutdown,默认为protect

Sw1#show    port-security  //查看端口安全配置

DHCP协议简介

DHCP协议简介:
典型的服务器-客户端模型;使用UDP作为其传输层协议;客户端可以从DHCP服务器那里获得能够自行完成配置的信息包括IP地址、默认网关地址、域名服务器地址和一些特定平台的信息。

DHCP工作原理

  • 客户端在网络中寻找DHCP服务器;
  • 服务器向DHCP客户端提供一个IP地址;
  • 客户端向DHCP服务器申请该IP地址的使用权;
  • 服务器向DHCP客户端确认它可以使用该IP地址。

配置:

Sw(config)#ip dhcp pool 111 //创建DHCP地址池

Sw(dhcp-config)#network 192.168.0.0 255.255.255.0 //设置地址范围

Sw(dhcp-config)#default-router 192.168.0.1 //设置默认网关

Sw(dhcp-config)#dns-server 114.114.114.114 //设置默认DNS

sw(config)#ip dhcp excluded-address 192.168.0.2